Resolved
All services are fully restored and operating normally.
Identified
The root cause has been identified, and we are actively working on a fix.
Investigating
We are investigating an outage affecting the Public API, Vendor Dashboard, and Partner Dashboard. Link redirects remain fully operational.